Go to previous topic
Go to next topic
Last Post 08/08/2019 4:20 PM by  TJ Mann
Using the --ignore option in daexport
 3 Replies
Author Messages
JimY
Private
Private
Veteran Member
(1438 points)
Veteran Member
Posts:510


Send Message:

--
09/18/2018 10:05 AM

    I am trying to use the --ignore option in the daexport command and it works if I use it like so:

     

    daexport -t 4 -o devj --ignore ActionRequest,PfiActivity dev

     

    I was told by Infor Support that you could specify the file names in a file and reference it in the command, but it doesn't work.  Below is what I have tried.  Has anyone else tried this?  Thank you.

     

    daexport -t 4 -o devy --ignore @exclude.txt dev

    daexport -t 4 -o devy --ignore exclude.txt dev

    daexport -t 4 -o devy --ignore '@exclude.txt' dev

    weeoooohhhh
    Software Engineer
    Private
    Basic Member
    (16 points)
    Basic Member
    Posts:6


    Send Message:

    --
    09/18/2018 10:12 AM

    I am able to get it to work when I specify the --ignore parameter before each object I'm trying to ignore like so (Also, I do not put a comma after each one as it doesn't like):

     

    daexport -o E:\Export TMDEV --ignore PfiActivity --ignore PfiActivityVariable --ignore

    JimY
    Private
    Private
    Veteran Member
    (1438 points)
    Veteran Member
    Posts:510


    Send Message:

    --
    09/18/2018 10:55 AM

    It does work when you specify the --ignore option once followed by the file names separated by a comma for me.  It just doesn't work if you try to reference a file that contains the file names to ignore.  

    TJ Mann
    Private
    Private
    Veteran Member
    (107 points)
    Veteran Member
    Posts:43


    Send Message:

    --
    08/08/2019 4:20 PM
    i used -ignore table1,table1,tabl3 and so on.


    ---