PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 04/16/2018 1:05 PM by  Greg Moeller
Lost Data Settings
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Katy Prince
Systems Analyst
Tompkins County
Advanced Member
(54 points)
Advanced Member
Posts:24


Send Message:

--
04/16/2018 10:43 AM
    Old reports have these data settings:
    Datasource in Report:
    Override Datasource
    Default User ID
    Default Password
    Confirm Password
    When Viewing Report:

    But when I try to publish a new report all of the above is missing... Anyone else ever run into this?

    See attached.
    Attachments
    Greg Moeller
    Private
    Private
    Veteran Member
    (3915 points)
    Veteran Member
    Posts:1391


    Send Message:

    --
    04/16/2018 10:52 AM
    It's been a while since we've seen this, but yes. We have seen this before.
    It was caused (at least for us) by the RAS server not being available, or started
    when the reports were published.
    Make sure your RAS server is up and re-publish.
    Katy Prince
    Systems Analyst
    Tompkins County
    Advanced Member
    (54 points)
    Advanced Member
    Posts:24


    Send Message:

    --
    04/16/2018 11:53 AM
    Thank you. Now... How do I know which server is my RAS server? I thought it would be the SAP Crystal Reports Server, but when I restarted the services in the Central Configuration Manager there, it didn't help.
    Greg Moeller
    Private
    Private
    Veteran Member
    (3915 points)
    Veteran Member
    Posts:1391


    Send Message:

    --
    04/16/2018 1:05 PM
    Go to Reporting Service Administration link
    Select Settings
    Look at the Default Report Application Server box

    If this has a value in it, that is your RAS server.

    If it is empy, you need to look at LBI_HOME\ReportingServices\Reporting Services.ear\erswar-10.6.0.0.war\WEB-INF\lib\clientSDKOptions.xml file (replacing LBI_HOME with whereever your LBI folder lives and possibly replacing the 10.6.0.0.war with whatever version you are running.
    Look at this file-
    You are not authorized to post a reply.