PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 3/22/2018 6:09 PM by  Rkapoor
Unable to see new productline in dbdef
 6 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Rkapoor
Admin
Private
Basic Member
(22 points)
Basic Member
Posts:10


Send Message:

--
3/21/2018 6:50 PM

    I have created new TEST productilne in backup server(V10 Env) using copy productline instructions.

    For some reason when i turn the security ON on the new productline, it disappears from dbdef and  appears back when i turn the security off on the productline. But if i login  as user root i do see this productline in dbdef, even if the security is turned on.











    Rkapoor
    Admin
    Private
    Basic Member
    (22 points)
    Basic Member
    Posts:10


    Send Message:

    --
    3/21/2018 6:54 PM
    I am logging as user lawson, with full access.
    Kwane McNeal
    President
    Private
    Veteran Member
    (1431 points)
    Veteran Member
    Posts:477


    Send Message:

    --
    3/21/2018 7:05 PM
    A few things:

    1) is the PL assigned to a security profile (beyond a certain build of 10.0.8, it’s required)
    2) does that security profile grant access to the new PL (again, required)
    3) are you current on env patches (there some builds of 10.0.8 and 10.0.9 where this is broken.)
    Rkapoor
    Admin
    Private
    Basic Member
    (22 points)
    Basic Member
    Posts:10


    Send Message:

    --
    3/21/2018 7:15 PM
    1, New Profile TST created, TEST productline is assigned to new profile TST.
    2, ??? not sure,
    3, we are on 10.0.9.0.1174
    Rkapoor
    Admin
    Private
    Basic Member
    (22 points)
    Basic Member
    Posts:10


    Send Message:

    --
    3/21/2018 7:24 PM
    On thing to bring to your attention is, when ran this command, I user lower care test as toPL, could that be isuse?
    lsload PROFILE dumpFileName -p TST -d test -a test -addRoleMapping

    because when in Profile assignment screen I assign data source(TEST) to Profile(TST), it alerts me with "the profile definition data source name of test does not match TEST - do yu wish to continue?"
    Kwane McNeal
    President
    Private
    Veteran Member
    (1431 points)
    Veteran Member
    Posts:477


    Send Message:

    --
    3/21/2018 10:02 PM
    It’s supposed to convert to uppercase, but it’s likely they didn’t code that. There’s a similar issue in sqldbcopy.

    Change it to uppercase for the PL names
    Rkapoor
    Admin
    Private
    Basic Member
    (22 points)
    Basic Member
    Posts:10


    Send Message:

    --
    3/22/2018 6:09 PM
    Yes, that was exactly the case,  I reran the lsload utility typing ToPL product line in upper case and it worked.
    Thanks a lot....
    You are not authorized to post a reply.