PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 08/07/2008 8:34 AM by  John Henley
Smart Notes missing link
 7 Replies
Sort:
You are not authorized to post a reply.
Author Messages
WRB
Private
Private
Basic Member
(27 points)
Basic Member
Posts:13


Send Message:

--
08/06/2008 4:07 PM
    Current version of LBI is 9.0.2.2.127 (FWS, RS, SN).
     
    We restart Tomcat each morning at 4:00 am, at  6:00am  we have a Smart Notes emailed via the scheduler.
     
    The Smart Notes that is emailed contain links that drills into other Smart Notes. What should happen is the user receives an email they click on the Department Name, sign on to LBI and the second filtered Smart Notes opens. 
     
    Since we reboot Tomcat each morning, the Smart Notes are emailed out, but the links do not work. Lawson GSC states that 9.0.3 is supposed to correct this issue otherwise we have to sign into LBI before the 6:00am schedule to re establish the links. 
     

    Any ideas? Can we create a bat file to sign on to LBI before the 6:00am schedule runs? If so, how would that look? Or does anyone have any ideas how to resolve this issue.  We can not afford to upgrade to 9.0.3 right now.

    Is anyone on LBI 9.0.3 are the bugs worked out yet?

    Thanks

    Matthew Nye
    Private
    Private
    Veteran Member
    (1532 points)
    Veteran Member
    Posts:514


    Send Message:

    --
    08/06/2008 4:12 PM
    Wendy,

    Hmmm, my first question would be why do you have to reboot tomcat? Seem that you shouldnt have to do this. If its because of memory issues Id say tune your infosets first. If you have the option, and im sure you already know this, move to WebSphere.

    What is the known bug that is fixed with 903? Ive never heard of this behavior.

    hth
    Matt
    If any of my answers were helpful an endorsement on LinkedIn would be much appriciated! www.linkedin.com/pub/matthew-nye/1a/886/760/
    WRB
    Private
    Private
    Basic Member
    (27 points)
    Basic Member
    Posts:13


    Send Message:

    --
    08/06/2008 4:42 PM

    Thanks for replying.  I just noticed I asked the question in the wrong folder, sorry.

    I'm not sure of the official bug name, I called GSC and they told me it was a bug reported in 9.0.2 and patched in 9.0.3.  When Tomcat reboots all the LBI links are lost, this did not sound correct to me so we tested. 

     We stopped rebooting Tomcat for a few days to see if this actually corrected the problem and it did.  If we don’t reboot Tomcat every couple of days then the Smart Note email stops completely. 

    The really sad news is we currently only have 6 Smart Notes, 2 are being sent out via email and drills to the other 4. I’ve only been here for 7 weeks but the server seems to be lacking; both Lawson and LBI DB are hosted.

    I agree moving to Websphere is a good idea, but it is currently not in the budget.  Any other idea's?

     

    Matthew Nye
    Private
    Private
    Veteran Member
    (1532 points)
    Veteran Member
    Posts:514


    Send Message:

    --
    08/06/2008 4:52 PM
    Make sure the full 1GB is allocated to the Tomcat instance. Sounds like youre running out of memory. If it is, have them provide log files to you as there may be a memory leak related to an inaccurately defined column in an infoset.

    Im still not completely understanding the "lost link" issue, sorry. Are the links JAVA, URL, LAL or Forms? Are they being created in the infoset or the notification?
    If any of my answers were helpful an endorsement on LinkedIn would be much appriciated! www.linkedin.com/pub/matthew-nye/1a/886/760/
    Greg Moeller
    Private
    Private
    Veteran Member
    (4034 points)
    Veteran Member
    Posts:1438


    Send Message:

    --
    08/06/2008 5:04 PM
    Wendy: If they are already on LSF9 on a Unix platform and using Websphere there.. the Windows version of Websphere comes along with that, so that you could use that for your LBI app and not have to worry about it not being "in the budget".
    At least it's worth talking to your Lawson sales/support people about!!
    WRB
    Private
    Private
    Basic Member
    (27 points)
    Basic Member
    Posts:13


    Send Message:

    --
    08/07/2008 7:01 AM
    Hello Matthew, I don't really understand the "lost Link" issue either. The links are used to drill back to another notification nothing special. I just don't understand how restarting Tomcat could break the links, but it does. GSC said we we sign into LBI before the 5:10am SN runs that the link would work. This I have not attempted, but if we schedule the SN during the day the link back to another SN works fine.

    LSF9 not in budget until 2010. I'll get with company hosting us to verify the 1 GB for Tomcat.

    Thanks everyone for the reply. I really appreciate your time.
    Matthew Nye
    Private
    Private
    Veteran Member
    (1532 points)
    Veteran Member
    Posts:514


    Send Message:

    --
    08/07/2008 8:12 AM

    and how are the link implemented, from the Notification or the InfoSet?  As for logging in auto-magic-ly, I know this is possible but I dont know how to do it. It has something to do with manipulating the Lawson login.htm file.

    Honestly, there doesnt seem to be any reason why you cant get these links working.  Post more details about them and lets see if we can get them working without the login.

    If any of my answers were helpful an endorsement on LinkedIn would be much appriciated! www.linkedin.com/pub/matthew-nye/1a/886/760/
    John Henley
    Private
    Private
    Senior Member
    (9788 points)
    Senior Member
    Posts:3280


    Send Message:

    --
    08/07/2008 8:34 AM
    Wendy, I moved this to the LSN forum...
    Thanks for using the LawsonGuru.com forums!
    John
    You are not authorized to post a reply.